Disc space

Hi, it seems I have run out of disc space. Is it possible to get more please?



the additional disk was added to your VM.


Thanks! Much appreciated!

I just uploaded my updated models and tried installing my environment again using Poetry. Seems I ran out of space again during the dependency installation. Could I please get a bit more space?


Hi there Chris,

The additional space was mounted on /mnt/data where you have 20 free Gigs (df -h /mnt/data) You might want to explicitly tell your code to install dependencies there.

I am having lots of trouble with this. My Poetry installation is stuck in limbo, thinking it’s installed but it’s not. Plus, I don’t think it’s possible to install dependencies via Poetry to a specific directory.

Instead I tried creating a venv. This worked within my software’s directory, but again I ran out of space. I tried creating the bin in /mnt/data, but when I use pip within the venv I get the same out of space on device error.

I am a bit confused and very frustrated, given the deadline is approaching. Is it possible to wipe my VM so I can start from scratch? Or is there something I am missing for installing libraries and dependencies?

Would it be possible to move your models to the /mnt/data directory? That would free up some space on your main drive.

That seemed to do the trick! Thank you!

But of course I’m into another issue. When I click Run in the GUI, I get no response at all. Is this because my Command is not legitimate? With Poetry, this is the command I would use in a regular shell:

~/.poetry/bin/poetry run python /Pan_Final/make_predictions.py -i “path” -o “results”

So this is the command I am attempting:

~/.poetry/bin/poetry run python /Pan_Final/make_predictions.py -i $inputDataset -o $outputDir

Can TIRA accept a command for Poetry? I’m guessing the “run python” is the issue. Should I just attempt to stop using Poetry and directly install my libraries and dependencies?

Thank you again for your assistance.

If it runs in a regular shell, then it will run from the GUI. I would ask you to try again, while we investigate.

I’ve just tried again. I also tried creating another software window and deleting it. Both the add software and delete buttons work, but I still get zero response from the run button.

Hey @cbagdon,
the shell commands are rather restricted in variety to avoid code injection issues.

I can’t assure that this will be working but maybe trying one of the following will help you:

  1. alias the command you’re using like
    alias run="~/.poetry/bin/poetry run python /Pan_Final/make_predictions.py"
  2. write a short bash script taking the inputDataset and outputDir as parameters and call that form the GUI
    ./new_script.sh -i $inputDataset -o $outputDir

Thankfully, somehow the software ran today, without changing anything.

But for some reason after about 15 minutes of running, the page changed to a " Oops! That page doesn’t exist or is private." error page. Now I only get this page when trying to go to tira.io, or my VM’s page. This happens on multiple devices whether I am logged in or not. I am guessing you guys are doing something with the main page?

Everything seems to working again.


1 Like