Tira Submission failure

Hello, there
When I tried to submit
Command:tira-run --input-dataset multi-author-writing-style-analysis-2024/multi-author-spot-check-20240428-training --image clef:0.2 --command ‘python /home/clef/model.py’
Error:tira-run: error: argument {upload}: invalid choice: “/home/clef/model.py’” (choose from ‘upload’)

I tried a lot of solutions, repackaging the image, changing the path, but never solved the problem

Dear @cookie0,

Thanks for reaching out!
It looks like the python /home/clef/model.py is not parsed as one string, but as two strings so that tira-run thinks that /home/clef/model.py is an independent argument which does not exist.

The reason for this is likely that the quotes are wrong. I.e., it should be ', but it currently is in the example that you pasted.

Could you please try this command:

tira-run --input-dataset multi-author-writing-style-analysis-2024/multi-author-spot-check-20240428-training --image clef:0.2 --command 'python /home/clef/model.py'

(I.e., with the ' as quote and not .)

Does this solve the problem?

Best regards,


yeah,I have solved

1 Like

Awesome, thanks for the response!

Please do not hesitate to contact me/us in case of questions/problems.
(We regularly review submissions and contact in case we see problems)

Best regards,