Unable to install tira python package

As mentioned in the software submission page, I tried to run the following command and it threw the error:
pip3 install tira
ERROR: Could not find a version that satisfies the requirement tira (from versions: none)
ERROR: No matching distribution found for tira

python --version
Python 3.6.8

Please help.

Dear Riya,

Thanks for reaching out and for you detailed report!
The tira script requires Python >=3.7, but you have 3.6.8.
Would it be possible for you to upgrade to >= 3.7?

Thanks and best regards,


I installed Python 3.7.x and was able to install pip and tira on top of it.
Now, on tira-cli login I am getting the following error. I am running this on my Windows 10 machine.

Traceback (most recent call last):
File “C:\Users\user1\AppData\Local\Programs\Python\Python37-32\lib\runpy.py”, line 193, in run_module_as_main
main”, mod_spec)
File “C:\Users\user1\AppData\Local\Programs\Python\Python37-32\lib\runpy.py”, line 85, in run_code
exec(code, run_globals)
File "C:\Users\user1\AppData\Local\Programs\Python\Python37-32\Scripts\tira-cli.exe_main
.py", line 4, in
File “C:\Users\user1\AppData\Local\Programs\Python\Python37-32\lib\site-packages\tira\tira_cli.py”, line 3, in
from tira.rest_api_client import Client as RestClient
File “C:\Users\user1\AppData\Local\Programs\Python\Python37-32\lib\site-packages\tira\rest_api_client.py”, line 1, in
import requests
File "C:\Users\user1\AppData\Local\Programs\Python\Python37-32\lib\site-packages\requests_init
.py", line 43, in
import urllib3
File “C:\Users\user1\AppData\Local\Programs\Python\Python37-32\lib\site-packages\urllib3_init_.py”, line 42, in
"urllib3 v2.0 only supports OpenSSL 1.1.1+, currently "
ImportError: urllib3 v2.0 only supports OpenSSL 1.1.1+, currently the ‘ssl’ module is compiled with ‘OpenSSL 1.1.0h 27 Mar 2018’. See: Drop support for OpenSSL<1.1.1 · Issue #2168 · urllib3/urllib3 · GitHub

Was able to proceed by downgrading urllib3 to v1.26.6

Dear Riya,

Nice that this worked!
If there are more of such version conflicts, we could also push to tira via github actions (we had good experiences so far with that, i.e., that the github action dockerizes the code, tests the docker image on a small dataset, and subsequently uploads it to tira). Under “Software Submission” on the submission page we have a step-by-step guide for this.

But if the version change solved it we are also fine :slight_smile:

Sorry for the inconvenience!

Best regards,